dev-util/meson: trivial bump from ::gentoo for 0.51
This commit is contained in:
parent
13a00c171d
commit
cd6b29ecd5
3
dev-util/meson/Manifest
Normal file
3
dev-util/meson/Manifest
Normal file
@ -0,0 +1,3 @@
|
|||||||
|
AUX meson-0.49-python3.5-tests.patch 1228 BLAKE2B 1cf444e239ec6c24f0fef9d20edf92e364c5c55debf61c115559cacb676596e98a9e01970661b16c4a95bfbf161d6c02e314bbe746979cb77c8f7f6dc5ce7fa6 SHA512 c856436331f6d80912e0519303051e49f4c2c08d348e575ff71b2628621ce752148bccf7aa348d0f27d7df11ff15ee96439d4438d0a2755e1f6c66d2be0ac942
|
||||||
|
DIST meson-0.51.0.tar.gz 1449793 BLAKE2B a1036191dcb883f5b7383b4f867425b480d38d1637540f166e153f4cf7a9861d6154860193ec9f859c5550090a1fa6fe09011c7d9c183475b4e6f8d2c20c9ee2 SHA512 e434dbb16bea658cd920617021f1f166ceffcabdcee512e893bf7c002d0955935b07e3b39707de77f1524e65b7f96ef5cd2b2a63d74cd8f4f2d610bc593b0d0f
|
||||||
|
EBUILD meson-0.51.0.ebuild 1716 BLAKE2B d68f12fb42796b9d394cffe42a9dcebe48105ccd3f862f69e4b0bb4fde5767740398faee47685b153e3a1ce250ff0fb2c802ba225186a109b0cf323e95b6257f SHA512 b88b89e704b997d6e9f1ff8ecb036b1c41bef82fbd26bb8876ea30dd9f993e0453b8cc67084d7158aa7840dd6756d820927350a0a7ba87330af7c1259a1091df
|
34
dev-util/meson/files/meson-0.49-python3.5-tests.patch
Normal file
34
dev-util/meson/files/meson-0.49-python3.5-tests.patch
Normal file
@ -0,0 +1,34 @@
|
|||||||
|
From 65192af2ff62a032a3f19d065c95e12b83aae709 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Simon McVittie <smcv@collabora.com>
|
||||||
|
Date: Fri, 11 Jan 2019 18:03:15 +0000
|
||||||
|
Subject: [PATCH] run_unittests: Use Python 3.5-compatible subprocess
|
||||||
|
invocation
|
||||||
|
|
||||||
|
subprocess.run() didn't get the encoding parameter until 3.6.
|
||||||
|
|
||||||
|
Signed-off-by: Simon McVittie <smcv@collabora.com>
|
||||||
|
---
|
||||||
|
run_unittests.py | 7 +++----
|
||||||
|
1 file changed, 3 insertions(+), 4 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/run_unittests.py b/run_unittests.py
|
||||||
|
index 342ad883..e1246140 100755
|
||||||
|
--- a/run_unittests.py
|
||||||
|
+++ b/run_unittests.py
|
||||||
|
@@ -5029,10 +5029,9 @@ class NativeFileTests(BasePlatformTests):
|
||||||
|
ret = subprocess.run(
|
||||||
|
["{}"] + extra_args,
|
||||||
|
stdout=subprocess.PIPE,
|
||||||
|
- stderr=subprocess.PIPE,
|
||||||
|
- encoding='utf-8')
|
||||||
|
- print(ret.stdout)
|
||||||
|
- print(ret.stderr, file=sys.stderr)
|
||||||
|
+ stderr=subprocess.PIPE)
|
||||||
|
+ print(ret.stdout.decode('utf-8'))
|
||||||
|
+ print(ret.stderr.decode('utf-8'), file=sys.stderr)
|
||||||
|
sys.exit(ret.returncode)
|
||||||
|
|
||||||
|
if __name__ == '__main__':
|
||||||
|
--
|
||||||
|
2.21.0
|
||||||
|
|
72
dev-util/meson/meson-0.51.0.ebuild
Normal file
72
dev-util/meson/meson-0.51.0.ebuild
Normal file
@ -0,0 +1,72 @@
|
|||||||
|
# Copyright 1999-2019 Gentoo Authors
|
||||||
|
# Distributed under the terms of the GNU General Public License v2
|
||||||
|
|
||||||
|
EAPI=7
|
||||||
|
PYTHON_COMPAT=( python3_{5,6,7} )
|
||||||
|
|
||||||
|
if [[ ${PV} = *9999* ]]; then
|
||||||
|
EGIT_REPO_URI="https://github.com/mesonbuild/meson"
|
||||||
|
inherit git-r3
|
||||||
|
else
|
||||||
|
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
|
||||||
|
KEYWORDS="alpha amd64 ~arm arm64 ~hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh ~sparc x86 ~x64-cygwin ~amd64-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
|
||||||
|
fi
|
||||||
|
|
||||||
|
inherit distutils-r1 toolchain-funcs
|
||||||
|
|
||||||
|
DESCRIPTION="Open source build system"
|
||||||
|
HOMEPAGE="http://mesonbuild.com/"
|
||||||
|
|
||||||
|
LICENSE="Apache-2.0"
|
||||||
|
SLOT="0"
|
||||||
|
IUSE="test"
|
||||||
|
RESTRICT="!test? ( test )"
|
||||||
|
|
||||||
|
RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
|
||||||
|
DEPEND="${RDEPEND}
|
||||||
|
test? (
|
||||||
|
dev-libs/glib:2
|
||||||
|
dev-libs/gobject-introspection
|
||||||
|
dev-util/ninja
|
||||||
|
dev-vcs/git
|
||||||
|
virtual/pkgconfig
|
||||||
|
)
|
||||||
|
"
|
||||||
|
|
||||||
|
python_prepare_all() {
|
||||||
|
# ASAN and sandbox both want control over LD_PRELOAD
|
||||||
|
# https://bugs.gentoo.org/673016
|
||||||
|
sed -i -e 's/test_generate_gir_with_address_sanitizer/_&/' run_unittests.py || die
|
||||||
|
|
||||||
|
distutils-r1_python_prepare_all
|
||||||
|
}
|
||||||
|
|
||||||
|
src_test() {
|
||||||
|
tc-export PKG_CONFIG
|
||||||
|
if ${PKG_CONFIG} --exists Qt5Core && ! ${PKG_CONFIG} --exists Qt5Gui; then
|
||||||
|
ewarn "Found Qt5Core but not Qt5Gui; skipping tests"
|
||||||
|
else
|
||||||
|
distutils-r1_src_test
|
||||||
|
fi
|
||||||
|
}
|
||||||
|
|
||||||
|
python_test() {
|
||||||
|
(
|
||||||
|
# test_meson_installed
|
||||||
|
unset PYTHONDONTWRITEBYTECODE
|
||||||
|
|
||||||
|
# test_cross_file_system_paths
|
||||||
|
unset XDG_DATA_HOME
|
||||||
|
|
||||||
|
${EPYTHON} -u run_tests.py
|
||||||
|
) || die "Testing failed with ${EPYTHON}"
|
||||||
|
}
|
||||||
|
|
||||||
|
python_install_all() {
|
||||||
|
distutils-r1_python_install_all
|
||||||
|
|
||||||
|
insinto /usr/share/vim/vimfiles
|
||||||
|
doins -r data/syntax-highlighting/vim/{ftdetect,indent,syntax}
|
||||||
|
insinto /usr/share/zsh/site-functions
|
||||||
|
doins data/shell-completions/zsh/_meson
|
||||||
|
}
|
Loading…
Reference in New Issue
Block a user