media-libs/freeglut: winnt support for 2.8.1-r1

This commit is contained in:
Danny Robson 2014-12-05 17:05:15 +11:00
parent a658aa9524
commit 056dd9a5ef
4 changed files with 93 additions and 0 deletions

View File

@ -0,0 +1,4 @@
AUX 2.6.0-GFX_radeon.patch 786 SHA256 ed6642c409bc32b4ee98cd371ea3d403ce293eabf2d06aad9d9913166e62ed89 SHA512 dd449990c97ac4b40a33acbbda9a81e92b454ca5fecd2a9a54c48c7a647bd3a74f1088d173dea8883f7ce072c554a306b03fa1ea6bd24be65080662145b32cd1 WHIRLPOOL d65a6b5221edc43867229172292edbc97c3009bc61cd406113930c12a4781fdd2c81cb6617cc99fd10257b0cfb11896456704557d9e2336cb4388177d0efa27e
AUX freeglut-2.4.0-bsd-usb-joystick.patch 755 SHA256 52ada965b1dc6abbb9ce0bbc00bf91452c6717b74016d21e0a10df24a0ffe83c SHA512 7aa28f277864357e9b2bb6e7fcd801bb9dd6e131fec8989aca26990cf59b60c3465030ea5068ca01cb7f46bf406c0f3fce2327affb7f288ee3026b5717717561 WHIRLPOOL 91710af0b3c06f36b65f51045e12f444329b4954268012422d0c6eafefc0a4f5f25f4b01b348256fdbce9956f766ee91773fc3cf8e28e0f9941ccd9b92930fb9
DIST freeglut-2.8.1.tar.gz 1005343 SHA256 dde46626a62a1cd9cf48a11951cdd592e7067c345cffe193a149dfd47aef999a SHA512 935fddfa197c5f0ec74c5f2005fe5a0ebfd39f4a402cc79363da7cfe2e8576263130e44bd7e4f6c07ea53d3137bd7ca8ee8db85c0a09f25508fcf1b9ed07052e WHIRLPOOL f191f870fa85b867f17ac3b69d18be386dd020b5f9c0fbc58814718986760570aa93cf4b2790daf944587d95a60408892fe68bd56f0dcc3f0f154c8a1ae33256
EBUILD freeglut-2.8.1-r1.ebuild 1509 SHA256 186f67c2a8885dd014e4cd2acc19d9997f7e439f170f6b9d0d9237b294cc99f5 SHA512 9d9c3e81c865f7523e801499b2f90cb49ba1769a5b50242207c5e4a572950d68dbeacf0d09478399740783efb7cbe70657188a9f5c10e0f44f2890a3d9a8c7bd WHIRLPOOL f0eb54b318e286300565a24a31a7d5d7b98e9117ea9a1383c74b7da70dfaee917bae5ac3bc875f337f23836d8d71131918b72e6e734ae2b18c8ffb2ca8bc8438

View File

@ -0,0 +1,28 @@
Index: src/freeglut_window.c
===================================================================
--- src/freeglut_window.c (Revision 832)
+++ src/freeglut_window.c (Arbeitskopie)
@@ -594,10 +594,9 @@
#if TARGET_HOST_POSIX_X11
if ( window )
{
- glXMakeContextCurrent(
+ glXMakeCurrent(
fgDisplay.Display,
window->Window.Handle,
- window->Window.Handle,
window->Window.Context
);
@@ -932,10 +932,9 @@
XSetWMProtocols( fgDisplay.Display, window->Window.Handle,
&fgDisplay.DeleteWindow, 1 );
- glXMakeContextCurrent(
+ glXMakeCurrent(
fgDisplay.Display,
window->Window.Handle,
- window->Window.Handle,
window->Window.Context
);

View File

@ -0,0 +1,16 @@
We disable BSD usb joystick support until upstream has a better support for it
so that it can at least build. For now it builds but does not link to libusbhid
so that libglut.so has undefined references to hid_* symbols and causes linking
errors later on in the build process.
--- freeglut-2.4.0/src/freeglut_joystick.c.old 2008-08-08 15:26:15 +0000
+++ freeglut-2.4.0/src/freeglut_joystick.c 2008-08-08 15:26:32 +0000
@@ -78,7 +78,7 @@
# include <errno.h>
# if defined(__FreeBSD__) || defined(__NetBSD__)
/* XXX The below hack is done until freeglut's autoconf is updated. */
-# define HAVE_USB_JS 1
+# undef HAVE_USB_JS
# if defined(__FreeBSD__) && __FreeBSD_version >= 500000
# include <sys/joystick.h>

View File

@ -0,0 +1,45 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/media-libs/freeglut/freeglut-2.8.1-r1.ebuild,v 1.11 2014/06/18 19:28:55 mgorny Exp $
EAPI=5
inherit autotools-multilib
DESCRIPTION="A completely OpenSourced alternative to the OpenGL Utility Toolkit (GLUT) library"
HOMEPAGE="http://freeglut.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~amd64-winnt"
IUSE="debug static-libs"
RDEPEND=">=virtual/glu-9.0-r1[${MULTILIB_USEDEP}]
>=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}]
!amd64-winnt? (
>=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
>=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
>=x11-libs/libXi-1.7.2[${MULTILIB_USEDEP}]
>=x11-libs/libXrandr-1.4.2[${MULTILIB_USEDEP}]
>=x11-libs/libXxf86vm-1.1.3[${MULTILIB_USEDEP}]
abi_x86_32? ( !app-emulation/emul-linux-x86-opengl[-abi_x86_32(-)] )
)"
DEPEND="${RDEPEND}
virtual/pkgconfig
!amd64-winnt? (
>=x11-proto/inputproto-2.3[${MULTILIB_USEDEP}]
>=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}]
)"
PATCHES=(
# Please read the comments in the patch before thinking about dropping it
# yet again...
"${FILESDIR}"/${PN}-2.4.0-bsd-usb-joystick.patch
)
HTML_DOCS=( doc/. )
multilib_src_configure() {
ECONF_SOURCE="${S}" econf \
$(usex amd64-winnt "--without-x" '')
}